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Using This Guide

Storage Manager is a general-purpose, administrative utility for updating, 
testing, and troubleshooting storage media (Avid® drives and Digidesign® 
DigiDrive® drives only) connected to Avid or Digidesign systems. Storage 
Manager is available for the following operating systems:

• Windows NT® operating system running on an Avid Unity™ 
MediaNetwork File Manager

• Windows® 2000 and Windows XP operating systems running on an 
Avid Unity MediaNetwork client or as a standalone system

• Mac OS® X operating system running on a standalone system

Who Should Use This Guide

This guide is intended for administrators responsible for installing, testing, 
and troubleshooting Avid and DigiDrive hard drives.

About This Guide

This guide provides instructions for the installation and use of Storage 
Manager. The Contents lists all topics included in the book, presented with the 
following overall structure:

• Chapter 1, “Installing Storage Manager,” describes how to install Storage 
Manager.

• Chapter 2, “Storage Manager Overview,” provides basic concepts that you 
should understand before using Storage Manager.
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• Chapter 3, “Using Storage Manager,” provides step-by-step instructions 
for using all of Storage Manager’s features, except hard drive tuning and 
testing. Hard drive tuning (Digidesign drives only) is described in 
Chapter 4, and hard drive testing is described in Chapter 5.

• Chapter 4, “Tuning Digidesign Drives,” describes how to run the 
Digidesign Drive Tuner for DigiDrive drives.

• Chapter 5, “Testing Hard Drives,” describes the various hard drive tests 
that you can perform with Storage Manager and provides step-by-step 
instructions on how to use them.

• Appendix A, “Interpreting Error Messages,” includes information on 
Storage Manager test results and the actions you should take if you 
discover a hard drive problem.

• Finally, a detailed Index helps you quickly locate specific topics.

Symbols and Conventions

Unless noted otherwise, the name “Storage Manager” applies to both 
Avid Storage Manager and Digidesign Storage Manager.

Unless noted otherwise, the material in this document applies to the Windows 
and Macintosh® operating systems. When the text applies to a specific 
operating system, it is marked as follows:

• (Windows) or (Windows only) means the information applies to the 
Windows NT, Windows 2000, and Windows XP operating systems.

• (Macintosh) or (Macintosh only) means the information applies to the 
Mac OS X operating system.

The majority of screen shots in this document were captured on a 
Windows XP system, but the information applies to both Windows and 
Macintosh systems. Where differences exist, both Windows and Macintosh 
screen shots are shown.

Avid documentation uses the following symbols and conventions.
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Symbol or Convention Meaning or Action

n A note provides important related information, 
reminders, recommendations, and strong suggestions.

c A caution means that a specific action you take could 
cause harm to your computer or cause you to lose data.

w A warning describes an action that could cause you 
physical harm. Follow the guidelines in this document 
or on the unit itself when handling electrical equipment.

> This symbol indicates menu commands (and 
subcommands) in the order you select them. For 
example, File > Import means to open the File menu 
and then select the Import command.

t This symbol indicates a single-step procedure. Multiple 
arrows in a list indicate that you perform one of the 
actions listed.

k This symbol represents the Apple or Command key. 
Press and hold the Command key and another key to 
perform a keyboard shortcut.

Margin tips In the margin, you will find tips that help you perform 
tasks more easily and efficiently.

Italic font Italic font is used to emphasize certain words and to 
indicate variables.

Courier Bold font Courier Bold font identifies text that you type.

Click Quickly press and release the left mouse button 
(Windows) or the mouse button (Macintosh).

Double-click Click the left mouse button (Windows) or the mouse 
button (Macintosh) twice rapidly.

Right-click Quickly press and release the right mouse button 
(Windows only).

Drag Press and hold the left mouse button (Windows) or the 
mouse button (Macintosh) while you move the mouse.

Ctrl+key
k+key

Press and hold the first key while you press the second 
key.
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Unless noted otherwise, the name “Avid drive” refers to the internal hard drive 
of the Avid or Digidesign system. Depending on your system’s setup, the 
internal hard drive might have a different name. Also, the material in this 
document applies to the Avid and Digidesign DigiDrive external hard drives.

If You Need Help

If you are having trouble using Storage Manager:

1. Retry the action, carefully following the instructions given for that task in 
this guide. It is especially important to check each step of your workflow.

2. Check for the latest information that might have become available after 
the documentation was published in one of two locations:

- If release notes are available, they ship with your application.

- If ReadMe files are available, they are supplied in your Avid 
application folder. ReadMe files are also available from Help.

n Release notes and ReadMe files are also available on the Avid Knowledge 
Center.

3. Check the documentation that came with your Avid application or your 
hardware for maintenance or hardware-related issues.

4. Visit the online Knowledge Center at www.avid.com/support. Online 
services are available 24 hours per day, 7 days per week. Search this 
online Knowledge Center to find answers, to view error messages, to 
access troubleshooting tips, to download updates, and to read/join online 
message-board discussions.

5. For Technical Support, please call 800-800-AVID (800-800-2843).

For Broadcast On-Air Sites and Call Letter Stations, call
800-NEWSDNG (800-639-7364).
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How to Order Documentation

To order additional copies of this documentation from within the 
United States, call Avid Sales at 800-949-AVID (800-949-2843). If you are 
placing an order from outside the United States, contact your local 
Avid representative.

Avid Educational Services

For information on courses/schedules, training centers, certifications, 
courseware, and books, please visit www.avid.com/training or call Avid Sales 
at 800-949-AVID (800-949-2843).
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Chapter 1
Installing Storage Manager

This chapter explains how to install the Storage Manager utility on Avid 
systems that you use to test and update hard drives. Storage Manager is 
preinstalled on some Windows and Macintosh Avid systems. If it is 
preinstalled on your system, go to Chapter 2. If it is not preinstalled, check 
either the installation CD-ROM that came with your Avid or DigiDrive hard 
drive or the Avid Web site (www.avid.com) for a standalone installer.

This chapter includes the following topics:

• Determining If Storage Manager Is Installed

• Installing Storage Manager (Windows)

• Installing Storage Manager (Macintosh)

Determining If Storage Manager Is Installed

To determine if Storage Manager is already installed:

t (Windows) Click the Start button, and select Programs > Avid > 
Utilities > Avid Storage Manager.

t (Macintosh) Navigate to Macintosh HD/Applications/Utilities/
Avid Storage Manager.

If it is properly installed, Storage Manager should open. If Storage Manager 
does not appear on the Start menu (Windows) or on the Macintosh HD 
(Macintosh), you need to install it.

http://www.avid.com
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Installing Storage Manager (Windows)

If Storage Manager is not installed on your Avid system, you can install it 
from the Avid or Digidesign CD-ROM that came with your Avid or DigiDrive 
hard drive. If your CD-ROM does not contain a copy of Storage Manager, you 
can download the utility from the Avid Knowledge Center at www.avid.com. 
Once you have located the utility, perform the following procedure to install it 
on your Avid system. 

n Storage Manager runs on systems that use the Windows 2000 or Windows XP 
operating system. Functionality is reduced when you test Avid Unity LANshare 
or Avid Unity LANshare EX drives from a client.

To install Storage Manager on a Windows system:

1. Do one of the following:

t Navigate to the CD-ROM drive:\disk1 folder.

t Navigate to the location where you saved the Storage Manager 
download file.

n The downloaded file is in a compressed format. You must uncompress the file 
before installing Storage Manager.

2. Double-click the Setup or Setup.exe icon.

The Storage Manager Setup window opens.

3. Click Next to proceed with the installation.

4. Select the country in which you purchased Storage Manager, and then 
click Next.

5. Click Yes to accept the license agreement.

6. Click Next to install Storage Manager to its default location, C:\Program 
Files\Avid\Utilities\Avid Storage Manager.

7. Click Next to perform a default Storage Manager installation.

8. Click Finish to close the Storage Manager Setup window.
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Installing Storage Manager (Macintosh)

Storage Manager installs when you install your Avid application on a 
Macintosh system. If it is not installed, check either the installation CD-ROM 
that came with your Avid or DigiDrive hard drive or the Avid Web site 
(www.avid.com) for a standalone installer.

http://www.avid.com
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Chapter 2
Storage Manager Overview

This chapter provides an overview of Storage Manager’s features and user 
interface.

This chapter includes the following topics:

• Introduction

• Understanding IDs

• The Main Window

• Toolbars and Menus

• Using Storage Manager with Other Utilities

Introduction

Storage Manager is a utility that you can use to work with Avid hard drives in 
your storage subsystem. Using Storage Manager, you can do the following:

• Identify Avid hard drives. For more information, see “Identifying Hard 
Drives” on page 43.

• Spin down Avid hard drives (SCSI and Fibre Channel only). For more 
information, see “Spinning Down Hard Drives” on page 44.

• Report and share test results by generating log files and sending them by 
e-mail to recipients that you specify. For more information, see “Sending 
Error Log and Configuration Files” on page 46.

• Update Avid hard drive firmware. For more information, see “Updating 
Hard Drive Firmware” on page 48.
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• Tune DigiDrive drives for optimal performance using the Storage 
Manager Drive Tuner. This feature replaces the DigiDrive Tuner. For 
more information, see “Using the Storage Manager Drive Tuner” on 
page 52.

• Exercise Avid hard drives using a variety of standardized or customized 
tests. For more information, see “Testing Your Hard Drives” on page 54.

• Obtain test status information useful for troubleshooting. For more 
information, see “Viewing Test Information” on page 57.

In addition to these features, the Storage Manager user interface provides a 
main window with two views, Physical view and Volume view, that provide 
information about your storage subsystem.

c Storage Manager tests or tunes DigiDrive and Avid hard drives on 
Digidesign systems only. It cannot test or tune other hard drives. For Avid 
hard drives on other Avid systems, use the Avid Startup utility to tune 
drives.

Understanding IDs

All of the devices connected to an Avid system — for example, hard drives 
and CD-ROM drives — must have unique IDs (identification numbers). The 
Avid system uses these IDs to distinguish the devices from each other and to 
direct traffic between itself and the devices. There are different types of IDs, 
and this section provides a brief overview of each type. These IDs are used 
throughout the Storage Manager user interface.
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The following figure shows how IDs are assigned to devices attached to an 
Avid system.

IDs in a Storage Subsystem

Each ID contains three parts — the bus ID, the device ID, and the LUN ID:

• Bus ID: Indicates the storage bus in the Avid system to which the drives 
are connected. Storage Manager can identify and use storage buses that 
are on host bus adapter boards or the system board. Host bus adapter 
boards can have multiple storage buses.

• Device ID: Indicates an individual device connected to a storage bus. 
Each device must have a unique ID. You can attach many types of devices 
to a storage bus; however, Storage Manager uses only the device IDs for 
the hard drives in your storage subsystem.

Device IDs are limited. A SCSI adapter board can accommodate 16 IDs. 
One ID is used for the SCSI bus adapter itself (typically ID 7), leaving 15 
IDs for any hard drives connected to it. A Fibre Channel adapter board 
using a Fibre Channel arbitrated loop can accommodate 126 IDs.

Device ID 3

Bus ID 3

Host bus 
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system
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Bus ID 1
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RAID Controller 
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• LUN ID: LUN ID stands for logical unit number ID. Storage Manager 
uses LUN IDs when you add a converter or RAID controller to your 
storage subsystem. Converters convert a bus’s drive interface from one 
type to another (for example, a SCSI bus to an IDE bus). Every hard drive 
attached to a converter has a unique LUN ID, and the converter has a 
device ID. RAID controllers map the storage connected to them into one 
or more storage groups identified by LUN IDs.

The Main Window

Storage Manager’s main window provides a visual display of your storage 
subsystem along with several status indicators. The main window has two 
views, Physical view and Volume view, which allow you to look at your 
storage from a physical perspective or a logical perspective. The following 
figure shows Storage Manager’s main window with Physical view active.

n You cannot see Physical view and Volume view concurrently.
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The remainder of this chapter describes the features in Physical view and 
Volume view. It also describes the toolbar buttons and their functions.

Physical View

Physical view is the default view when you open Storage Manager (unless you 
reset the user preferences to Volume view). Physical view presents, in an 
expandable tree structure, the physical characteristics of your storage 
subsystem: all of the storage adapter boards in your Avid system, any 
converters or RAID controllers, and the hard drives attached to them.

Physical View 
button

Top 
toolbar

Side toolbar

Volume View button Menu bar
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c Physical view shows your internal and external hard drives. Do not select 
the internal system drive when you are working with Storage Manager’s 
features. Drives that contain mounted volumes (visible in Volume view) 
can be selected but not tested.

The following figure shows the main window with Physical view active and 
highlights the view’s most important features. These features are described in 
the following sections.

Partition status indicatorHard drive descriptionAvailability/testing status indicator

Unit 
indicator

Adapter 
board 
description

Converter 
or RAID 
controller 
description
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Adapter Board Description

An adapter board description includes:

• Bus ID (a bus on the Avid system where the hard drive is connected)

• Manufacturer’s name

• Model number

The following illustration shows the description for an adapter board.

Converter or RAID Controller Description

A converter or RAID controller description appears in the branch beneath the 
adapter board to which it is connected. Converter and RAID controller 
descriptions branch again to display descriptions of all the hard drives 
connected to them. You can recognize a converter’s hard drives because their 
descriptions begin with LUN instead of HDD (hard disk drive). You can 
recognize a RAID controller’s hard drives because their descriptions include 
their RAID classification (RAID 0, RAID 5, or JBOD).

n JBOD (Just a Bunch of Disks) mode is also available but only for diagnostic 
purposes. User data storage is not supported in JBOD mode.

A converter or RAID controller description includes:

• Converter or controller indicator

• Bus ID, device ID, and LUN ID for the converter or controller

• Manufacturer’s name

• Model number

• RAID classification

ManufacturerBus ID Model
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The following illustration shows the descriptions for a RAID controller and a 
JBOD enclosure.

Hard Drive Description

A hard drive description includes:

• Drive connection type. The drive connection type is either HDD or LUN. 
HDD indicates that the hard drive is connected directly to the adapter 
board. LUN indicates that the hard drive is connected to the adapter board 
by way of a converter.

• Bus ID, device ID, and LUN ID for the hard drive. For information on ID 
types, see “Understanding IDs” on page 16.

• Manufacturer’s name.

• Model number.

• Drive size, where 1 GB equals 1024 bytes x 1024 bytes x 1024 bytes. 
Drive sizes typically appear smaller than the manufacturer’s stated size 
because drive manufacturers state drive size in decimal billions of bytes.

The following illustration shows the description for a hard drive.

Unit Indicator

Each unit in the storage subsystem (hard drive, adapter board, converter, or 
RAID controller) has a drive icon. If FC appears on a drive’s icon, the drive is 
a Fibre Channel drive. If FC does not appear on a drive’s icon, the drive is a 
SCSI or IDE drive.

Bus ID, device ID, LUN IDConverter or controller indicator

Manufacturer

Model

RAID classification

Manufacturer

ModelBus ID, device ID, LUN ID

Drive connection type Size
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Availability/Testing Status Indicator

To the left of the hard drive description is the availability/testing status 
indicator. The following table describes the various availability/testing status 
indications.

n Hard drives with an availability/testing status of Passed, Failed, or Updated 
change their status back to Ready when you rescan the storage subsystem. For 
more information on rescanning, see “Rescanning the Storage Subsystem” on 
page 45.

Availability/Testing Status Indications  

Status Description

Ready The hard drive is ready to read and write data.

Unavailable The device is not accessible. The drive might be 
turned off, spinning up, having a problem, or not 
supported (for example, it is a non-Avid drive). The 
device might be an enclosure or a CD-ROM drive 
that is not testable.

Testing The hard drive is currently being tested.

Passed The hard drive has passed its most recent test.

n If the test aborts before the hard drive has 
failed, the status indication is Passed.

Failed The hard drive has failed its most recent test.

Updating Updated firmware is currently being downloaded to 
the hard drive (Windows only).

Updated Firmware has been downloaded to the hard drive 
(Windows only).

Broken The hard drive is having a problem.



 Chapter 2 Storage Manager Overview

24

Partition Status Indicator

To the right of the hard drive description is the partition status indicator. The 
following table describes the various partition status indications.

Partition Status Indications  

Status Description

Striped The hard drive has partition and file system 
information on it and is part of a stripe set of drives.

Unstriped The hard drive has partition and file system 
information on it but is not part of a stripe set.

Raw The hard drive has no partition or file system 
information on it.

Unsupported The hard drive has an unsupported file system.

Mixed The hard drive has several partitions with different 
format types.

Remus The hard drive’s partition information indicates it was 
used for local Fibre Channel storage 
(Mac OS 9.x or earlier; drive format is not compatible 
with Mac OS X).

Remus Stripe The hard drive’s partition information indicates it was 
used for striped local Fibre Channel storage (Mac OS 
9.x or earlier; drive format is not compatible with 
Mac OS X).

Apple The hard drive’s partition information indicates it was 
used as a boot drive for a Macintosh system (Mac OS 
9.x or earlier).

ATTO The hard drive’s partition information indicates it was 
connected to a Macintosh system by an ATTO™ 
adapter board (Mac OS X).

ATTO Stripe The hard drive’s partition information indicates it was 
part of a stripe set connected to a Macintosh system 
by an ATTO adapter board (Mac OS X).

MediaNet Stripe The hard drive’s partition information indicates it was 
part of a MediaNetwork Fibre Channel shared storage 
environment.
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Volume View

Volume view presents, in an expandable tree structure, a logical view of the 
volumes you have created for your storage subsystem and the hard drives that 
make up those volumes.

FAT 16, FAT 32, 
FAT 32 XINT13

The hard drive’s partition information indicates it has 
been formatted for use in an MS-DOS® environment 
(Windows).

LDM The hard drive’s partition information indicates it is a 
dynamic drive (Windows 2000 and Windows XP).

LDM Stripe The hard drive’s partition information indicates it is a 
stripe dynamic drive (Windows 2000 and 
Windows XP).

NTFT The hard drive’s partition information indicates it is 
part of a fault-tolerant partition (Windows 2000 and 
Windows XP).

NTFS Stripe The hard drive’s partition information indicates it is a 
stripe dynamic drive (Windows 2000 and 
Windows XP).

IFS The hard drive’s partition information indicates the 
drive has an older MS-DOS partition.

RD0, RD5, JBD For drives in a MediaRAID enclosure, the partition 
information indicates if the drive is part of a RAID 0 
or RAID 5 enclosure, or if it is a JBOD set.

Partition Status Indications (Continued)  

Status Description
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The following figure shows the main window with Volume view active and 
highlights the view’s most important features. These features are described in 
the following sections.

Volume view has many of the same features as Physical view, such as:

• Hard drive description

• Availability/testing status indicator

• Partition status indicator

• Unit indicator

For a description of these features, see “Physical View” on page 19. The 
following sections describe features that are specific to Volume view.

Volume name

Availability/testing status indicator Partition status indicatorHard drive description

Mount status 
indicator

Stripe set 
drive total

Unit indicator

Raw drives list
RAID enclosure
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Raw Drives List

Volume view lists all of the unformatted drives in a Raw drives list. To view 
your raw drives, expand the Raw drives list.

Volume Name

Each volume has a specific name. A volume is a logical storage unit that either 
uses one physical drive or spans multiple drives. Volumes that span multiple 
drives are called stripe volumes. You can expand each volume name to show 
the drives that make up that volume.

Mount Status Indicator

To the left of the volume name is the mount status indicator. The following 
table describes the various mount status indications.

Stripe volume name

Stripe 
drives

Mount Status Indications  

Status Description

Mounted The hard drive is currently mounted on your Avid 
system.

Unmounted The hard drive is not currently mounted on your Avid 
system.

Broken The volume is made up of multiple hard drives that 
are part of a stripe set, and one or more drives in the 
set are unavailable. If this status is shown for a raw 
drive, then the drive is having a problem.
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RAID Enclosures

RAID enclosures are displayed as separate volumes. Each volume expands to 
show the hard drives that comprise the RAID enclosure.

Stripe Set Drive Total

If a volume is comprised of a stripe set of drives, the number of drives in the 
set is shown to the left of the volume’s mount status indicator.

Toolbars and Menus

Storage Manager has two toolbars, one on the top and one on the side, which 
allow you to access features quickly and easily. All of the buttons in the top 
toolbar have menu equivalents that you can access from the menu bar.

Top Toolbar and Menu Equivalents

The following table describes the buttons in the top toolbar and provides their 
equivalent menu commands.

Top Toolbar Buttons  

Button Button Name Description Menu Equivalent

Physical View Displays Physical view in the main window. Select View > Physical.

Volume View Displays Volume view in the main window. Select View > Volume.

Console Opens the Console window, which allows you 
to view test results and firmware updating 
results.

Select View > Console.

Rescan System 
Configuration

Initiates a rescan of the entire storage 
subsystem, and updates Physical view and 
Volume view with the results.

Select Edit > Rescan 
Configuration.
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Update Firmware Initiates a firmware download to an Avid hard 
drive.

Select Edit > Update 
Firmware.

User Preferences Opens the User Preferences dialog box, which 
allows you to set the default behavior for a 
variety of features.

Select Edit > User 
Preferences.

Save 
Configuration

Saves the current configuration of your storage 
subsystem. Avid Customer Support uses this 
configuration file for diagnostic purposes.

Select File > Save 
Configuration.

Send File Opens the Send File dialog box, which allows 
you to send a log file by e-mail to a recipient 
you specify.

Select File > Send File.

Exit Closes Storage Manager. Select File > Exit.

Help Displays Storage Manager Help contents. Select Help > Contents.

Top Toolbar Buttons (Continued)  

Button Button Name Description Menu Equivalent
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Side Toolbar

The following table describes the buttons in the side toolbar. These buttons do 
not have equivalent menu commands.

Side Toolbar Buttons  

Button Button Name Description

Identify Identifies the hard drives currently selected in the main window by 
causing the drives’ activity LED to blink.

n The Identify feature is not supported when you test Avid Unity 
LANshare or Avid Unity LANshare EX drives from a client.

Spin Down Spins down the shuttles currently selected in the main window in 
preparation for swapping the shuttles. This feature parks the heads, 
stops the disk rotation, and puts the drives in Idle mode.

For more information on the Spin Down feature, see “Spinning 
Down Hard Drives” on page 44.

n The Spin Down feature is not supported for IDE, IEEE 1394-
compliant (FireWire®), or MediaRAID drives.

Test Opens the Test window that you use to set up and run tests on your 
Avid hard drives.

Tune Tunes hard drives for optimal performance in Avid systems 
(Digidesign drives only).

Close Closes Physical view or Volume view, depending on which view is 
active.

Help Opens a context-sensitive Help window that contains information 
about the main window’s current view (Physical or Volume).
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Using Storage Manager with Other Utilities

You can use Storage Manager with other Avid configuration and diagnostic 
utilities designed to set up and troubleshoot your Avid components. These 
utilities include:

• Avid System Test Pro: This utility tests the Avid editing system to make 
sure the Avid components and peripheral boards are functioning properly.

• AvidStartup: This utility ensures that the storage media performance 
parameters are set correctly for your Avid software.
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Chapter 3
Using Storage Manager

This chapter provides information on using Storage Manager’s features, 
except hard drive tuning and hard drive testing. For information on these 
topics, see the following chapters:

• Chapter 4, “Tuning Digidesign Drives”

• Chapter 5, “Testing Hard Drives”

This chapter includes the following topics:

• Opening and Closing Storage Manager

• Setting User Preferences

• Selecting Hard Drives

• Viewing Hard Drive Information

• Identifying Hard Drives

• Spinning Down Hard Drives

• Rescanning the Storage Subsystem

• Saving the Storage Subsystem Configuration

• Sending Error Log and Configuration Files

• Updating Hard Drive Firmware
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Opening and Closing Storage Manager

To open Storage Manager on a Windows system:

t Click the Start button, and select Programs > Avid > Utilities > 
Avid Storage Manager.

To open Storage Manager on a Macintosh system:

t Navigate to Macintosh HD/Applications/Utilities/Avid Storage Manager, 
and then double-click the Storage Manager icon.

To close Storage Manager:

t Click the Exit button in the top toolbar, or select File > Exit.

Setting User Preferences

You can set user preferences that determine the default behavior of Storage 
Manager as follows:

• The initial view for the main window (Physical view or Volume view)

• The default window’s location, size, and “look and feel”

• The default e-mail addresses for sending and receiving log and 
configuration files

To set user preferences:

1. Click the User Preferences button in the top toolbar, or select Edit > User 
Preferences.

The User Preferences dialog box opens.



Setting User Preferences

35

2. Click the tab for the preferences you want to set. See “Window User 
Preferences” on page 36, “View User Preferences” on page 36, and “E-
mail User Preferences” on page 37 for descriptions of the options on each 
tab.

3. Make your changes, and then click Apply.

4. Repeat steps 2 and 3 to set the options on the other tabs.

5. When you have finished setting user preferences, click OK to close the 
User Preferences dialog box.

6. Close Storage Manager, and then reopen it to make your new user 
preferences active.
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Window User Preferences  

Option Type Option Description

Default Location Top, Left of Display 
(Default)

The Storage Manager window opens 
in the upper left corner of your 
display.

Centered in Display The Storage Manager window opens 
in the center of your display.

Current Position The Storage Manager window opens 
in the same location where it was last 
closed.

Default Size Optimized for 
Display (Default)

The Storage Manager window is 
sized as large as possible, up to 
800 x 600 pixels.

Maximized in 
Display

The Storage Manager window is 
sized to fill the entire display.

Current Size The Storage Manager window opens 
with the same dimensions as when it 
was last closed.

View User Preferences  

Option Type Option Description

Default Window Physical View 
Window (default)

When it opens, Storage Manager 
displays Physical view.

Volume View 
Window

When it opens, Storage Manager 
displays Volume view.

Main Window Only When it opens, Storage Manager 
displays the main window with 
neither Physical view nor Volume 
view showing.
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Default Look & 
Feel

CDE/Motif Storage Manager uses CDE 
(Windows and Macintosh) or Motif® 
style windows (Macintosh only).

MacOS Adaptive Storage Manager uses Mac OS X 
style windows (Macintosh only).

Metal Storage Manager uses Metal style 
windows.

Windows Storage Manager uses Windows 
style windows (Windows only).

E-mail User Preferences  

Option Description

Recipient E-mail 
Addresses

The default e-mail addresses for the recipients of log and 
configuration files.

Sender E-mail 
Address

The default e-mail address for the sender of log and 
configuration files.

Outgoing Mail 
(SMTP) Server

The name of the SMTP server used to deliver the
e-mail. To use this feature, the system running Storage 
Manager must have a network connection to an SMTP 
server.

E-mail Subject The default subject line for the log and the configuration 
file e-mail messages.

View User Preferences (Continued)  

Option Type Option Description
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Selecting Hard Drives

Selecting the correct hard drives in both Physical view and Volume view is 
important before you use any of the features in Storage Manager, especially if 
you are running a destructive test.

c Running a destructive test destroys the data on a hard drive. Do not run a 
destructive test on your internal boot drive or on any drive that has data 
you want to keep.

Selecting a Single Drive

The procedure for selecting a single drive in Physical view and in Volume 
view is identical.

To select a single drive in Physical view or Volume view:

t Click the check box next to the hard drive description to enable it. If you 
select a drive that is part of a stripe set, Storage Manager will ask you if 
you want to select all the drives in the set or just the one you clicked.

Selecting a single 
drive in Physical 
view

Selecting a single 
drive in Volume 
view
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Selecting Multiple Drives

The procedures for selecting multiple drives differ slightly in Physical view 
and in Volume view.

To select multiple hard drives in Physical view:

t Click the check box next to the adapter board description to select all of 
the drives that are connected by that adapter board.

To select multiple hard drives in Volume view:

t Click the check box next to the volume name to select all of the drives that 
make up that volume.

n You can also use the Shift and Ctrl keys to select multiple drives.

Viewing Hard Drive Information

Storage Manager has two features for viewing hard drive information. One 
feature provides details on the physical hardware for a drive. The other feature 
provides information on the volumes that use all or a portion of the hard 
drive’s storage space.

Selecting multiple 
drives in Physical 
view

Selecting multiple 
drives in Volume 
view
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Viewing Hardware Information

To view the hardware information for hard drives:

1. In either Physical view or Volume view, click the check boxes for the hard 
drives for which you want information. If you select a drive that is part of 
a stripe set, Storage Manager asks you if you want to select all drives in 
the set or just the drive you selected.

2. Right-click (Windows) or Control+click (Macintosh) a selected hard drive 
description, and select Device Information. 

The Device Information dialog box opens. If you have selected multiple 
hard drives, then several dialog boxes open, one on top of the other.

For detailed descriptions of the information contained in the Device 
Information dialog box, see “Device Information Dialog Box” on page 41.

3. Click OK to close the Device Information dialog box.

n To view the Device Information dialog boxes that are hidden, click OK to close 
the topmost dialog box, or click the topmost dialog box and drag it away from 
the dialog box behind it.
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Device Information Dialog Box  

Label Description or Comment

Device A description of the selected hard drive. 

This information includes the drive type, its bus ID, its device 
ID, and its LUN ID. For example, HDD 1:1:0 indicates a hard 
drive on bus 1 with a device ID of 1 and a LUN ID of 0.

n Bus numbers for SCSI drives start at 0. Bus numbers 
for FireWire drives start at 64.

Format The type of partition that currently exists on the hard drive. 
For complete information, see “Partition Status Indications” 
on page 24.

Vendor The manufacturer of the hard drive.

Model The model number of the hard drive.

Serial Number The serial number of the hard drive.

Series Code Each Avid hard drive is assigned a series code that indicates 
its drive type (for example, 7,200 RPM, second generation 
10,000 RPM, and so forth). 

You use the series code when striping drives. Drives should 
have the same series code (that is, they are the same type) in 
order to be striped together. If you stripe drives of different 
types together, the performance of the stripe set is limited to 
the speed of the slowest drive in the set. Drives with 
dissimilar series codes generally should not be striped 
together.

Capacity The storage capacity of the hard drive. The first number is 
based on the industry standard—1024 bytes equals one 
kilobyte (KB) — and the second number is the actual 
physical byte count on the drive.
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Viewing Volume Information

To view the volume information for hard drives:

1. In either Physical view or Volume view, click the check boxes for the hard 
drives on which you want information.

2. Right-click (Windows) or Control+click (Macintosh) a selected hard drive 
description, and select Device Volumes.

Status The status of the hard drive. Possible values are:

• Ready: The drive is available and ready for testing.

• Not Ready: The drive is not ready for testing

• Unavailable: The device is not a hard drive (for example, 
it is a CD-ROM drive).

• Testing: The drive is in the process of being tested.

• Passed: The drive has passed its most recent test.

• Failed: The drive has failed its most recent test.

n A drive’s label changes from Passed to Ready only 
after you have rescanned the storage subsystem by 
using the Rescan feature or by reopening Storage 
Manager.

Manufacturing 
Date

The date the hard drive was manufactured, in Julian notation. 
For example, 01/360 indicates the drive was manufactured on 
the 360th day of the year 2001.

n The manufacturing date is not available for all drives.

Firmware 
Revision

The firmware revision of the hard drive.

Servo Revision The servo code revision of the hard drive. Servo code is 
responsible for keeping the drive heads on track.

n The servo revision is not available for all drives.

Device Information Dialog Box (Continued)  

Label Description or Comment
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The Device Volumes dialog box opens. If you have selected multiple hard 
drives, then several dialog boxes open, one on top of the other.

The Device Volumes dialog box contains the following information:

- The hard drive description includes the drive type, its bus ID, its 
device ID, and its LUN ID (for example, HDD 1:10:0).

- The names of any volumes that use all or a portion of the hard drive’s 
storage capacity.

In addition to the volume name, the dialog box provides the volume’s 
mount status (Mounted, Unmounted, or Broken), its stripe status 
(Striped or Unstriped), and its size.

3. Click OK to close the Device Volumes dialog box.

Identifying Hard Drives

The Identify button in the side toolbar provides a visual aid that allows you to 
match the hard drive descriptions in the main window with the physical hard 
drives in your storage subsystem.

To identify hard drives:

1. In either Physical view or Volume view, click the check boxes for the hard 
drives you want to identify.

2. Click the Identify button in the side toolbar.
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The Identify Device dialog box opens, and the drive activity LEDs for the 
drives you selected start to blink.

n The drive activity LEDs blink for approximately 1 second on and 1 second off.

3. Click OK to close the Identify Device dialog box and stop the blinking 
LEDs.

Spinning Down Hard Drives

You can use Storage Manager to spin down your Avid shuttles. The Spin 
Down feature parks the drive heads, stops the drive from rotating, and ensures 
that you can safely swap the drive without loss of data or damage to the drive.

You should use the Identify feature to identify drives before spinning them 
down (see “Identifying Hard Drives” on page 43). Only removable drives that 
you plan to remove should be spun down. If you spin down a fixed drive or an 
internal system drive, you must turn it off and then turn it on for the drive to 
spin up again.

n The Spin Down feature is not supported for IDE, IEEE 1394-compliant 
(FireWire), or MediaRAID drives.

To spin down hard drives:

1. Make sure the hard drives you want to spin down do not have any volumes 
that are mounted. If they do, then unmount the volumes before spinning 
down the drives.

2. In Physical view or Volume view, click the check boxes for the hard drives 
you want to spin down.

3. Click the Spin Down button in the side toolbar.
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4. The hourglass pointer appears, and Storage Manager waits 30 seconds to 
ensure that all of the drives are spun down. When the hourglass pointer 
disappears, the spin down is complete.

n For information about spinning up a shuttle, see your shuttle enclosure 
documentation. In most cases, the shuttle spins up when you insert it in the 
shuttle enclosure. If you inadvertently spin down a fixed drive, you must turn 
the drive power switch off and then on to spin the drive back up for use.

Rescanning the Storage Subsystem
You can manually initiate the Rescan feature by clicking the Rescan System 
Configuration button in the top toolbar, or by selecting Edit > Rescan 
Configuration. When the Rescan feature is active, Storage Manager scans all 
of the hard drives in your storage subsystem and updates the information in the 
main window.

n Hard drives with an availability/testing status of Passed, Failed, or Updated 
change their status back to Ready when you rescan the storage subsystem.

Rescanning might not find hard drives or shuttles that you added to the Avid 
system since the last system boot. If you have added hard drives since the last 
system boot, you might need to restart your system.

To rescan for new drives:

t (Windows) Run Disk Manager to rescan the buses, and then click the 
Rescan System Configuration button to locate the new hard drives. If the 
new hard drives still do not appear, then reboot the system.

t (Macintosh) Restart the Macintosh system and run Storage Manager to 
locate the new hard drives.

Saving the Storage Subsystem Configuration

In Storage Manager, you can save your storage subsystem’s configuration to a 
log file. Avid Customer Support uses the information in this file for diagnostic 
purposes.
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To save the storage subsystem configuration:

1. Click the Save Configuration button in the top toolbar, or select 
File > Save Configuration.

The Save Configuration dialog box opens.

2. Click the Browse button, and then navigate to the location where you want 
to save the configuration file.

3. Type a name for the file. The default file name is:

ASMConfig-MM.DD.YY.txt

where MM is the month, DD is the day, and YY is the year the file was 
created.

4. Click OK, and then click OK again to close the Save Configuration dialog 
box and save the file.

Sending Error Log and Configuration Files

You can send error logs and configuration files directly from Storage Manager 
to other locations through e-mail. You can use this feature to send error and 
configuration information to Avid Customer Support for a diagnosis of 
storage-related problems.

c Before using the e-mail feature, make sure the computer running Storage 
Manager has a network connection to an SMTP server.

n Error logs are generated while testing your hard drives. For more information, 
see Chapter 5.
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To send a log file:

1. Click the Send File button in the top toolbar, or select File > Send File.

The Send File dialog box opens.

The dialog box is partially filled in with information from the e-mail 
preferences you set (see “Setting User Preferences” on page 34). You can 
accept this information, or you can override it by typing new information 
in the text boxes.

2. Click the Browse button to locate the error log or configuration file you 
want to send.

The Select File dialog box opens.

3. Select the file you want to send, and then click OK to close the Select File 
dialog box.

n You can type the file name in the File text box. If the file does not exist in the 
directory where Storage Manager is installed — by default, C:\Program 
Files\Avid\Utilities\Avid Storage Manager (Windows) or 
Macintosh HD/Applications/Utilities/Avid Storage Manager (Macintosh) — 
you must type the entire path.

4. Click OK to send the file and to close the Send File dialog box.
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Updating Hard Drive Firmware

c Do not perform this procedure unless directed to do so by Avid Customer 
Support.

You can use Storage Manager to update the firmware on your Avid hard 
drives. When you use this feature, all hard drives that are acceptable 
candidates for the updated firmware package are updated automatically. You 
cannot select specific hard drives for updating. A drive is an acceptable 
candidate for updating if it is the correct type of drive for the updated 
firmware, and its current version of firmware is earlier than the version of the 
updated firmware.

Obtaining an Updated Firmware Package

Updated firmware packages are distributed through the following:

• Avid Knowledge Center

• Storage Utilities CD-ROM

c Always close Storage Manager before retrieving firmware updates.

To retrieve an updated firmware package from the Avid Knowledge 
Center:

1. Go to www.avid.com.

2. Click the Support tab, and then select Online Support.

3. Under the Knowledge Center heading, click Downloads.

The Knowledge Center opens in the Downloads tab.

4. Locate the firmware update, and then download the file to the following 
location: 

(Windows) C:\Program Files\Avid\Utilities\Avid Storage 
Manager\FirmwarePackages

(Macintosh) Macintosh HD/Applications/Utilities/Avid Storage 
Manager/FirmwarePackages

n You can use the Search feature to find the update. You can also click Storage 
Utilities Table at the top of the Downloads tab and select the update from the 
Storage Utilities Download table.

http://www.avid.com
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n If you installed Storage Manager in a directory other than the default, 
download the firmware update to the FirmwarePackages directory in that 
location instead.

n If you do not have a FirmwarePackages folder, you must create one and copy 
the firmware package files into the folder.

5. Uncompress the update file.

To retrieve an updated firmware package from the Storage Utilities CD-
ROM:

1. Insert the Storage Utilities CD-ROM into the CD-ROM drive.

2. Navigate to the Storage Manager directory on the Storage Utilities CD-
ROM.

3. Copy the firmware update package from the Storage Manager directory to 
the following location: 

(Windows) C:\Program Files\Avid\Utilities\Avid Storage 
Manager\FirmwarePackages

(Macintosh) Macintosh HD/Applications/Utilities/Avid Storage 
Manager/FirmwarePackages

n If you installed Storage Manager in a directory other than the default, copy 
the firmware update to the FirmwarePackages directory in that location 
instead.

n If you do not have a FirmwarePackages folder, you must create one and copy 
the firmware package files into the folder.

Updating Hard Drives

After downloading the firmware update package, you are ready to update your 
Avid hard drive or MediaRAID enclosure.

To update the firmware for your Avid hard drive:

1. Open Storage Manager.

2. Click the Update Firmware button in the top toolbar, or select 
Edit > Update Firmware.
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Storage Manager checks for drives and enclosures that require updating, 
prints the list in the Console window, and checks for available firmware 
update files. A dialog box opens, informing you of the number of drives 
and enclosures to be updated and asking if you want to continue.

3. Click Yes to continue. 

Storage Manager updates any Avid hard drives that are the correct type for 
the firmware update and that currently have an earlier version of firmware. 
The Console window displays the progress of the update for each drive 
and enclosure.

c Do not close Storage Manager or turn off hard drives when performing a 
firmware update. Doing so might cause the drives to become inoperable, 
requiring them to be returned to Avid for replacement at the discretion of 
Avid Customer Support.

When the update is complete, an Updated label displays next to all 
updated drives listed in the Physical View Window.



Chapter 4
Tuning Digidesign Drives

This chapter has detailed information on tuning Digidesign DigiDrive drives 
for optimal performance. The Storage Manager Drive Tuner feature provides 
the ability to set the mode pages on DigiDrive drives for use with Pro Tools®, 
AVoption™, and AVoption|XL systems.

n Drive Tuner is supported on DigiDrive SCSI drives only. You cannot tune 
DigiDrive FireWire drives.

This chapter includes the following topics:

• Pro Tools System Prerequisites (Windows)

• Pro Tools System Prerequisites (Macintosh)

• Using the Storage Manager Drive Tuner

Before you use Drive Tuner to optimize your DigiDrive drives, first check the 
following to make sure your system is ready:

• The DigiDrive drives are connected to the SCSI host bus adapter board.

• The Pro Tools, AVoption, or AVoption|XL system is turned on.

• The DigiDrive drives are turned on.

• If you are using a Macintosh system, the DigiDrive drives are visible on 
the desktop.

• If you are using a Windows system, the DigiDrive drives are visible in the 
My Computer window or in Windows Explorer.

n If the DigiDrive drives are not visible, see the Troubleshooting section of the 
DigiDrive Guide included on the DigiDrive CD-ROM.
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Pro Tools System Prerequisites (Windows)

Before you use the Storage Manager Drive Tuner on your DigiDrive drives in 
a Windows system, format your DigiDrive drives with the Windows Disk 
Administrator or the Windows Disk Management utility. For more 
information, see the DigiDrive Guide that came with your DigiDrive drives.

Pro Tools System Prerequisites (Macintosh)

Before you use the Storage Manager Drive Tuner on your DigiDrive drives in 
a Macintosh system, initialize your drives with the ATTO ExpressStripe utility 
(included with Pro Tools TDM Macintosh systems). 

n Do not use the Digital Audio mode page settings in the ATTO ExpressStripe 
utility. Storage Manager Drive Tuner sets the optimal mode pages for Pro 
Tools systems.

Using the Storage Manager Drive Tuner

You need to run the Storage Manager Drive Tuner once when your Pro Tools 
system is first set up, and then each time you add a new DigiDrive drive to the 
system.

To use the Storage Manager Drive Tuner:

1. Open Storage Manager.

The Storage Manager main window opens showing all of the attached 
storage devices.

2. Click the Tune button in the side toolbar.

Storage Manager searches your Pro Tools system for DigiDrive drives, 
and then sets the drive mode pages. 

When Drive Tuner is finished, the message appears, “Mode page check 
complete. X devices checked, Y tuned,” where X is the number of DigiDrive 
drives mounted on the system and Y is the number of drives tuned.



Chapter 5
Testing Hard Drives

This chapter provides detailed information on the tests you can perform on 
your Avid hard drives and DigiDrive drives with Storage Manager.

This chapter includes the following topics:

• Nondestructive and Destructive Tests

• Testing Your Hard Drives

• Test Templates

• Test Parameters

• Error Messages

Nondestructive and Destructive Tests

There are two types of tests you can perform with Storage Manager: 
nondestructive and destructive.

• Nondestructive tests only read the data on the hard drive. They do not 
write any data to the hard drive.

• Destructive tests write data to the drive and then read that data. The tests 
then compare the written data to the original data to verify that the write 
and read functions of the hard drive are working correctly. These tests 
destroy any data and the file system structure that are on the drive.

c Running a destructive test destroys all the data on a hard drive. Do not 
run a destructive test on your internal boot drive or on any drive that has 
data you want to keep.
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n Destructive tests do not remove data stored on hard drives sufficiently for a 
full security erase.

Testing Your Hard Drives

To perform a test you must:

1. Set up the test either by using one of Avid’s test templates or by specifying 
the test parameters yourself.

2. Run the test.

3. Review the test results.

The following sections provide instructions for performing these tasks. For 
more detailed descriptions of the test templates and the test parameters, see 
“Test Templates” on page 59 and “Test Parameters” on page 61.

Using a Test Template

Avid has created four test templates to aid you in testing your hard drives. 
Each template has its own test parameters that are set automatically. For 
detailed descriptions of the templates, see “Test Templates” on page 59.

To use a test template:

1. Select one or more drives to test.

2. Click the Test button in the side toolbar.
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The Test window opens.

3. Click the Template pop-up menu, and select a test template. The test 
parameters in the remainder of the Test window are set according to the 
template you selected.

4. To run the test using the template parameters, follow the instructions in 
“Running a Test” on page 56.

Creating a Custom Test

You can create a custom test by modifying an existing template to fit your 
needs.

To create a custom test:

1. Select one or more drives to test.

2. Click the Test button in the side toolbar.

The Test window opens.
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3. Click the Template pop-up menu, and select a test template. 

4. Change any test parameters in the remainder of the Test window. The 
Template pop-up menu automatically changes to User Selected to indicate 
that you have customized the template.

5. To run the test using the custom parameters, follow the instructions in 
“Running a Test” on page 56.

Running a Test

Once you have set the test parameters by using an existing template or by 
creating a custom test, you are ready to run the test.

c Running a destructive test destroys all data on a hard drive. Do not run a 
destructive test on your internal boot drive or on any drive that has data 
you want to keep. Use the Identify feature to verify that you are testing the 
correct drive (see “Identifying Hard Drives” on page 43).

If you run a test from a client in a LANshare environment, test coverage is 
limited as follows:

• SCSI or Fibre Channel drives do not allow for soft error reporting and data 
reallocation.

• IDE drive serial numbers are not available.

• Reallocated block count is not available.

To run a test:

1. After setting the test parameters, click the Start button in the Test window.

If you select a destructive test, a message box opens, warning you that the 
test will permanently delete data on your drive. Click Yes to continue.

The test starts running, and the Status indicator at the bottom of the Test 
window begins tracking the test. This indicator tracks each pass of the 
test, not the test as a whole.

2. Use the following options to control the test while it is running:

- To pause the test, click the Pause button (the button label then changes 
to Resume). Click the Resume button to restart the test at the point it 
paused.

Storage Manager retains the present state of the test and all test 
parameters during a pause. 
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- To stop the test, click the Stop button. The test parameters are saved 
for a future restart, but all other testing information (elapsed time, 
error counts, and so forth) are reset.

- To view the test results as the test is being run, click the Console 
button.

The Console window opens. For more information on the Console 
window, see “Viewing Test Information” on page 57.

Viewing Test Information

You can view test information in two ways: by using the Console window or 
by looking at the error log file (if you opted to create one during the test).

t To view test status while the test is running, use the Console window.

t To view test status after the test has finished, look at the error log file.

Test status information includes:

• A list of all the drives connected to the Avid system, including the drive 
type, bus ID, device ID, and LUN ID

• The type of test being run

• The set of test parameters used to perform the test

• A list of the drives being tested

• The status of each drive that is being tested

• Error messages

• The total number of blocks transferred for each drive (read and write 
blocks)

You can also view a summary of the test while it is running, while it is paused, 
or after it has finished. A test summary has a line for each drive under test and 
a line for each pass of the test. Test summaries include:

• The drive’s bus ID, device ID, and LUN ID

• The test pass number

• The number of read commands

• The number of sectors read

• The number of write commands

• The number of sectors written
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• The number of errors

• The number of reallocated blocks

• The maximum, minimum, and average times for the read and write 
commands, in milliseconds

• The total number of I/Os per second for the entire storage subsystem

n A test’s status information is always followed by a summary at the end of the 
test in both the Console window and in the log file.

To view test information using the Console window:

1. Open the Console window using one of the following methods:

t In the Test window, click the Console button.

t Click the Console button in the top toolbar.

t Select View > Console.

The Console window opens, displaying test information.

2. To view a summary of the test, click the Summary button.

3. When you are finished looking at the information in the Console window, 
click the Close button.
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To view test information in a log file:

t (Windows) The log file is an ASCII text file. Open the file in Notepad. If it 
is too large for Notepad, open the file in WordPad.

t (Macintosh) The log file is an ASCII text file. Open the file in TextEdit. If 
it is too large for TextEdit, open the file in a word processing application.

n You can also send your log files to a recipient that you specify. For more 
information, see “Sending Error Log and Configuration Files” on page 46.

Test Templates

The following table describes Storage Manager’s test templates. Each 
template uses a specific set of test parameters that are described in “Test 
Parameters” on page 61.

Test Templates  

Test Description Test Parameters

Extended Test 
(nondestructive)

This test provides an overall check of 
the storage subsystem. It 
nondestructively reads random blocks 
on the disk. Each pass reads the entire 
surface and then runs a random read 
test for approximately 60 minutes. You 
set the number of passes and the test 
length for the random read test, in 
minutes.

Test Type: Sequential Read/Random Read

Log File: Keep Log

Name: ASMLog-MM.DD.YY.txt

Error Halt: None

Test Data Pattern: Random

Test Length: Full Surface + 60 Minutes

Number of Passes: 1

n All other options are disabled.

Quick Check 
(nondestructive)

This test provides a quick indication of 
any serious problems in the storage 
subsystem. It nondestructively reads 
random blocks on each drive, and it 
runs for 30 minutes.

Test Type: Random Read

Log File: Keep Log

Name: ASMLog-MM.DD.YY.txt

Error Halt: None

Test Length: 30 Minutes

Number of Passes: 1

n All other options are disabled.
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Surface Scan 
(nondestructive)

This test reads the entire surface area 
of a selected Avid drive. You run it 
primarily to detect media errors on 
selected drives.

When you use this test, you are 
prompted to choose whether or not to 
automatically reallocate any blocks 
that have media errors. Reallocating 
bad blocks scrubs the disk surface 
clean of media defects.

If you choose to reallocate bad blocks, 
Storage Manager reallocates a bad 
block’s address to a good block and, if 
possible, copies the data from the bad 
block to the good block. If the original 
block contains unreadable data, the 
block is considered damaged and 
Storage Manager marks it as bad. 
Writing data to the reallocated block 
erases Storage Manager’s bad mark 
and writes good data into the 
reallocated block.

Test Type: Surface Scan

Log File: Keep Log

Name: ASMLog-MM.DD.YY.txt

Error Halt: None

Number of Passes: 1

n All other options are disabled.

Verify 
(nondestructive)

This test sequentially reads the entire 
surface area of a selected Avid drive. 
The test verifies errors on the drive, but 
it does not reallocate data for hard 
(nonrecoverable) media error bad 
blocks. The test does reallocate data 
for soft (recoverable) media error bad 
blocks.

This test usually is faster than a 
Surface Scan because it does not 
transfer data to memory.

n This test is not available for 
IDE or FireWire drives.

Test Type: Verify

Log File: Keep Log

Name: ASMLog-MM.DD.YY.txt

Error Halt: None

Test Length: Full Surface

Number of Passes: 1

User Selected This test is automatically selected 
when you modify a test template.

User Selected, by its definition, indicates that 
you have set your own custom parameters.

Test Templates (Continued)  

Test Description Test Parameters
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Test Parameters

The following table describes the test parameters you see in the Test window. 
The first parameter, Test Type, is divided into nondestructive and destructive 
tests.

Test Parameters  

Parameter Options

Test Type 
(nondestructive)

Random Read (default): This test picks a random starting point on the drive and 
a random number of sectors to test. It then reads the drive’s data, beginning at the 
random starting point and ending after the random number of sectors are read.

Convergence/Divergence Read: This test picks a random number of sectors to 
test. It then reads that number of sectors at the beginning of the drive. After the 
beginning of the drive is read, the test goes to the end of the drive and reads the 
same random number of sectors. The test then returns to where it left off at the 
beginning of the drive, picks a new random number of sectors, and repeats the 
same process. The test continues until it reads the entire drive twice. The 
Convergence/Divergence test is useful for identifying problems with the drive 
heads or with the drive’s servo system.

Sequential Read: This test reads the data on the drive from the beginning sector 
to the last sector.

Sequential Read/Random Read: This test starts by reading the data on the drive 
from the beginning sector to the last sector. It then picks a random starting point 
on the drive and a random number of drive sectors to test. The test reads the data 
beginning at the random starting point and ending after the random number of 
sectors are read. This random read is repeated for the specified test length.

Verify: This test reads data on the drive from the beginning sector to the last 
sector. This test identifies errors, but it does not transfer data to memory or 
reallocate blocks that have errors.

End of 
Drive

Beginning 
of Drive

This read starts at the 
beginning of the drive.

This read starts at the 
end of the drive.
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Test Type (destructive) Random Write/Read: This test picks a random starting point on the drive and a 
random number of drive sectors to test. It then writes data to the drive, reads the 
data back, and compares it to the original data. Writes and reads are done in pairs; 
that is, the test writes to a group of sectors, reads the data back, writes to another 
group of sectors, reads the data back, and so on until the test is completed.

Sequential Write/Read: This test writes data from the beginning of the drive to 
the end of the drive, reads that data back from beginning to end, and compares it to 
the original data.

Sequential Write/Random Read: This test writes data from the beginning of the 
drive to the end of the drive. It then picks a random starting point on the drive and 
a random number of drive sectors to test. The test reads the data beginning at the 
random starting point and ending after the random number of sectors are read. 
This random read is repeated for the specified test length.

Surface Scan: This test scans the entire surface area of the drive. It is run 
primarily to detect media errors. When you select this test, you are prompted to 
choose whether or not to automatically reallocate any blocks that have media 
errors, effectively scrubbing the disk surface clean of media defects. If you choose 
to reallocate blocks, this test will become destructive if any media errors are found 
and reallocated. If not, the test is nondestructive.

Format Test: This test performs a low-level format on the drive. You should use 
this test only when directed to do so by Avid Customer Support. If you stop this 
test before it is completed, the drive might be rendered inoperable, requiring the 
drive to be returned to Avid for replacement. This test cannot be used with IDE or 
FireWire drives.

Random Write: This test picks a random starting point on the drive and a random 
number of drive sectors. It then writes data between those two points. This test is 
useful for diagnostics.

Sequential Write: This test writes data from the beginning of the drive to the end 
of the drive. This test is useful for diagnostics.

Test Parameters (Continued)  

Parameter Options
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Log File Keep Log: Select this option to keep a log file for the tests you are running. Error 
logs are cumulative on a daily basis. An error log is appended with information 
from each test you run during a single day (as indicated by the computer’s internal 
date at the start of the test). When the date changes, a new error log is started. 
However, if a test runs over the course of several days, only one log file is 
generated for the entire test.

No Log: No error log is generated while your tests are run.

n For more information on the naming conventions for error log files, see the 
Name parameter.

Name When you select the Keep Log option, the Name text box is enabled. This box 
contains the name of the log file to be generated during testing. By default, this 
file name has the following format:

ASMErrorLog-MM-DD-YY.txt

You can overwrite the default file name with a name you specify by typing it in the 
Name text box. You must type the entire path if you are saving the file to a 
directory other than the default directory. You can also use the Browse button to 
specify a file name and a location for the log file.

n On Macintosh systems, the file name is preceded by the following path 
notation: ../../../../. This saves the file in a location separate from the 
Storage Manager utility.

Test Parameters (Continued)  

Parameter Options
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Error Halt None (default): The test continues even when it encounters an error, except when 
it encounters a catastrophic error. Catastrophic errors stop the test because they are 
not likely to be corrected and they fill the error log with redundant error 
information.

Any Error: The test stops when any drive encounters an error, regardless of the 
error type.

Media Error: The test stops when any drive encounters a nonrecoverable media 
error. A media error is an error in the magnetic drive media, for example, a bad 
sector on the drive.

Nonrecoverable Error: The test stops when any drive encounters a 
nonrecoverable error. Nonrecoverable errors include the following:

• A unit attention result that is not the result of a drive power-up or a SCSI Reset 
command

• An illegal request error

• An aborted command error

• Most driver errors

Catastrophic Error: The test stops when it encounters a catastrophic error. 
Catastrophic errors include the following:

• A drive seems to have “disappeared” or is nonexistent

• A drive not ready error

• A hardware error

• A data protection error

• Any error not recognized by Storage Manager

User Defined: The test stops when an error count that you specified is reached. 
The error count applies to any error type.

Errors If you select User Defined as your Error Halt parameter option, type the number of 
errors required before the test stops in the Errors text box. The number you type 
must be greater than 5, representing the maximum number of errors for each drive 
in the test.

Test Parameters (Continued)  

Parameter Options



Test Parameters

65

Data Compare Mode Compare All Data (default): For write/read tests, the data written to a hard drive 
and then read back is compared to the original data for discrepancies.

No Data Compare: No data comparison is made between the data written to a 
hard drive during a write/read test and the original data.

Compare First Sector: For write/read tests, the first 512 bytes of data written to a 
hard drive and then read back are compared to the original data for discrepancies.

Test Data Pattern Random (default): Random data is written to the drive.

Alternating: The data written to the drive uses alternating words comprised of all 
0s (zeros) or all 1s (ones).

Incrementing Byte: The data is written using an incrementing byte pattern where 
the 00 byte is never used. Skipping the 00 byte ensures that as the data repeats 
itself, it never falls on sector boundaries. This prevents the repetition of the pattern 
from masking possible data corruption problems.

Incrementing Word: The data is written using an incrementing word pattern.

User Defined: This option allows you to specify a number greater than 5 to be 
used as the repeating pattern.

Pattern If you select User Defined as your Test Data Pattern parameter option, type a 
number greater than 5 in the Pattern text box.

Test Length 30 Minutes (default): The test runs for 30 minutes and then stops.

60 Minutes: The test runs for 60 minutes and then stops.

120 Minutes: The test runs for 120 minutes and then stops.

User Defined: The test runs for the amount of time you specify in the Minutes 
text box. It is applicable to random tests only.

Minutes If you select User Defined as your Test Length parameter option, type the number 
of minutes that the test is to run before it stops in the Minutes text box.

Number of Passes 1 (default): The test runs once and then stops.

Infinite: The test runs until you manually stop it by clicking the Stop button in the 
Test window.

User Defined: The test runs for the number of passes specified in the Passes text 
box. A pass is completed for a sequential test either when the whole drive has been 
tested or when the time period for the test ends.

Test Parameters (Continued)  

Parameter Options
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Error Messages

The error messages in the Console window or in the error log files give you 
valuable information about the state of your hard drives. For descriptions of 
the most common errors and how to correct them, see Appendix A.

Passes If you select User Defined as your Number of Passes parameter option, type the 
number of passes required before the test stops in the Passes text box.

Test Parameters (Continued)  

Parameter Options
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Interpreting Error Messages

This appendix provides information on the error messages you might see in 
the Console window and the steps you can take to fix the errors. 

Error Messages and Corrective Actions

The following table describes the most common error messages that might be 
generated while you test Avid hard drives, and includes actions you can take to 
diagnose and fix problems.

n Error messages are referred to as “sense keys” in the Storage Manager 
Console window.

n Some sense keys provide additional information about the error.

Error Messages  

Error Message Description Comment or Action

00 NO SENSE The operation completed 
successfully with no errors.

None required.

01 RECOVERED ERROR The operation completed 
successfully with some recovery 
action performed by the drive.

Recovered errors usually are not a major 
concern. Run the Surface Scan test, and 
rerun the test that had the errors.

02 NOT READY The drive cannot be accessed. 
User intervention might be 
required to correct this condition. 

Wait 2 minutes, and rerun the test. If the 
error reoccurs, turn the drive’s power off and 
then on, wait 2 minutes, and rerun the test. If 
the error persists, replace the drive.
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03 MEDIUM ERROR A 03 - 11 error indicates that the 
test terminated with an 
unrecoverable error probably 
caused by a flaw in the media or 
an error in the recorded data. 

Run the Surface Scan test, enabling block 
reassignments, and rerun the test that failed.

A 03 - 31 error indicates a format 
corruption problem. This might 
occur after a firmware download. 
It might also occur if a low-level 
drive format was started and not 
completed. 

Run the Format test, and do not interrupt or 
turn off the hard drive or the Avid system 
until the reformatting is complete.

04 HARDWARE ERROR The hard drive detected an 
unrecoverable hardware failure 
while performing the test or 
during a self-test.

Turn the drive’s power off and then on, and 
rerun the test. If the error reoccurs, replace 
the drive.

05 ILLEGAL REQUEST There was an illegal parameter in 
the test.

This is a software error, not a hardware 
error, and it should not be seen unless the 
software contains a bug.

06 UNIT ATTENTION The removable media has been 
changed or the hard drive has 
been reset or power cycled. 

This is a normal occurrence after power 
cycling the drive or after rebooting your 
Avid system.

This error might be reported at the 
beginning of a test. If the error is reported 
after the start of a test, check the drive’s 
cabling, termination, and adapter board. 

If the error continues, turn off the first drive 
and rerun the test. If the error persists, turn 
on the first drive and turn off another drive, 
and rerun the test. Continue to cycle through 
the drives until the error is no longer 
reported. The drive that is turned off at this 
point needs to be replaced.

Error Messages (Continued)  

Error Message Description Comment or Action
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0B ABORTED 
COMMAND

The hard drive aborted the test. This usually indicates a bus problem caused 
by a cable, a terminator, or an adapter board 
seating problem.

Tighten all cable and terminator connectors. 
Reseat the adapter board and rerun the test. 
If the error persists and the drives are 
connected with daisy-chained cables (device 
to device), proceed as follows:

1. Reconfigure the cables to test half the 
drives, move the terminator to the last 
drive still connected in the chain, and 
rerun the test. 

2. If the error is no longer reported, add 
one drive at a time to the daisy chain and 
rerun the test. 

3. If the error reoccurs, replace the last 
cable that you added and rerun the test. 

4. If the error is still reported, remove the 
last drive you added and continue with 
the next drive until all the drives have 
been successfully added to the bus and 
the errors are no longer reported. 

5. Replace either the cable or the drive that 
failed. 

n If you reconfigure the cables to use 
half the drives and the error still 
occurs, reconfigure the cables to use 
the other half of the drives and 
perform steps 1 to 5 again.

Error Messages (Continued)  

Error Message Description Comment or Action
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A
Adapter boards

Fibre Channel 17
Physical view 21
SCSI 17

Availability/testing status 23, 45
Avid System Test Pro 31
AvidStartup 31

B
Bus ID 17
Buttons

Close 30
Console 28, 58
Exit 29, 34
Help 29, 30
Identify 30, 43
Physical View 28
Rescan System Configuration 28, 45
Save Configuration 29, 46
Send File 29, 47
Spin Down 30, 44
Test 30, 54, 55
Tune 30, 52
Update Firmware 29, 49
User Preferences 29, 34
Volume View 28

C
Close button 30
Configuration

saving 46
sending 46

Console button 28, 58
Console window 57, 58, 66
Convergence/Divergence Read test 61
Converters

Physical view 21

D
Data Compare Mode parameter 65
Destructive tests 53
Device ID 17
Device information

Capacity 41
Firmware Revision 42
Format 41
hard drive 41
Manufacturing Date 42
Model 41
partition 41
Serial Number 41
Series Code 41
Servo Revision 42
Status 42
Vendor 41
viewing 40

Device volume information 42

Index
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Devices
connecting 17
ID 17

Drive Tuner
Macintosh prerequisites 52
using 52
Windows prerequisites 52

E
E-mail

log and configuration files 37, 47
user preferences 37

Error Halt parameter 64
Error logs 47, 57, 63, 66
Error messages

ABORTED COMMAND 69
HARDWARE ERROR 68
ILLEGAL REQUEST 68
MEDIUM ERROR 68
NO SENSE 67
NOT READY 67
RECOVERED ERROR 67
sense keys 67
UNIT ATTENTION 68

Errors
catastrophic 64
media 64
nonrecoverable 64
user defined 64

Errors parameter 64
Exit button 29, 34
Extended test 59

F
Features

ID 16
overview 15

Fibre Channel
adapter board 17
ID 17

Firmware
locating updates 48
updating 48, 49

Format test 62, 68

H
Hard drives

capacity 41
custom test 55
HDD 21
identifying 43
LUN 21, 22
optimizing 51
partition 24
Physical view 19, 22
RAID controller 21
raw 24
Raw drives list 27
selecting 38, 39
spinning down 44
stripe drives 24, 27, 28
testing 53, 54, 56
tuning 51, 52
updating firmware 49
viewing information 39

Hardware information 40
HDD (hard disk drive) 21, 22
Help button 29, 30

I
ID (identification number)

Bus 17
described 16
Device 17
LUN 18

Identify button 30, 43
Identifying hard drives 43
Installing

Macintosh 13
overview 11
Windows 12

J
JBOD (Just a Bunch of Disks) 21, 25
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K
Keep Log option 63

L
Log File parameter 63
Logging

errors 46, 57
naming log files 63
sending log files 46
storage subsystem configuration 45
tests 63

LUN ID (logical unit number) 18, 21, 22

M
Main window

default size 36
overview 18
Physical view 18, 19
toolbars 28
user preferences 36
Volume view 18, 25

Minutes parameter 65
Mount status indicator 27

N
Name parameter 63
No Log option 63
Nondestructive tests 53
Number of Passes parameter 65

P
Partition status indicator 24
Partitions 24
Passes parameter 66
Pattern parameter 65
Physical view

adapter board 21
availability/testing status 23
converter 21
described 19

hard drive 19
hardware information 40
partition status indicator 24
RAID controller 21
selecting a single hard drive 38
selecting multiple hard drives 39
unit indicator 22
volume information 42

Physical View button 28
Preferences

See User preferences

Q
Quick Check test 59

R
RAID controllers

Physical view 21
RAID enclosures

RAID classification 25
updating firmware 49
Volume view 28

Random Read test 61
Random Write test 62
Random Write/Read test 62
Raw drives 24, 27
Rescan System Configuration button 28, 45
Rescanning 45

S
Save Configuration button 29, 46
SCSI

adapter board 17
ID 17

Send File button 29, 47
Sense keys 67
Sequential Read test 61
Sequential Read/Random Read test 61
Sequential Write test 62
Sequential Write/Random Read test 62
Sequential Write/Read test 62



Index  A B C D E F H I J K L M N P Q R S T U V W

74 AVID CONFIDENTIAL DRAFT VERSION 5/11/04

Side toolbar
Close button 30
Help button 30
Identify button 30, 43
Spin Down button 30, 44
Test button 30, 54, 55
Tune button 30, 52

Spin Down button 30, 44
Spinning down hard drives 44
Storage capacity 41
Storage configuration

log files 45
saving 45

Stripe drives 24, 27, 28
Subsystem configuration 45
Surface Scan test 60, 62, 67, 68

T
Templates

See Test templates
Test button 30, 54, 55
Test Data Pattern parameter 65
Test Length parameter 65
Test parameters

Data Compare Mode 65
Error Halt 64
Errors 64
Log File 63
Minutes 65
Name 63
Number of Passes 65
Passes 66
Pattern 65
Test Data Pattern 65
Test Length 65
Test Type (destructive) 62
Test Type (nondestructive) 61

Test templates
Extended 59
Quick Check 59
selecting 54
Surface Scan 60, 67, 68
User Selected 60
Verify 60

Test Type parameter 61, 62
Testing

Console window 57
error logs 57, 59
hard drives 56
LANshare client 56
options 54
summary 57, 58

Tests
Convergence/Divergence Read 61
custom test 55
destructive 53, 56
error logs 63
Extended 59
Format 62, 68
nondestructive 53
pausing 56
Quick Check 59
Random Read 61
Random Write 62
Random Write/Read 62
Sequential Read 61
Sequential Read/Random Read 61
Sequential Write 62
Sequential Write/Random Read 62
Sequential Write/Read 62
stopping 56
Surface Scan 62
test templates 54, 59
User Selected 60
Verify 61
viewing information 57

Toolbars
side toolbar 30
top toolbar 28

Top toolbar
Console button 28, 58
Exit button 29, 34
Help button 29
menu equivalents 28
Physical View button 28
Rescan System Configuration button 28, 45
Save Configuration button 29, 46
Send File button 29, 47
Update Firmware button 29, 49
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User Preferences button 29, 34
Volume View button 28

Tune button 30, 52
Tuning 51, 52

U
Unit indicator 22
Update Firmware button 29, 49
User preferences

appearance 36
CDE/Motif 37
e-mail 37
Main window 36
options 36

User Preferences button 29, 34
User Selected test 60
Utilities

Avid System Test Pro 31
AvidStartup 31

V
Verify test 60, 61
Volume

information 42
name 27

Volume view
description 25
hardware information 40
mount status indicator 27
RAID enclosure 28
Raw drives list 27
selecting a single hard drive 38
selecting multiple hard drives 39
volume information 42
volume name 27

Volume View button 28
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